Danger

The Adventure docs are currently a work in progress and supplement the Javadocs. Some areas may have limited coverage or may not be entirely up to date. Feel free to join our Discord if you have any questions.

adventure-platform-fabric#

v5.2.1: 🌍 adventure-platform-fabric 5.2.1#

Released on 2022-04-21 - GitHub

This is a patch release of adventure-platform-fabric for 1.18.2, fixing compatibility with Fabric Loader 0.14.0 and newer.

🐛 Fixes

Incompatibility with Fabric Loader 0.14.0 - #26

Full Changelog: v5.2.0...v5.2.1

v5.2.0: 🌍 adventure-platform-fabric 5.2.0#

Released on 2022-03-02 - GitHub

This is a very small release -- it supports Minecraft 1.18.2 (but not any older versions), and bundles Adventure 4.10.0.

There are no other changes from 5.1.0.

v5.1.0: 🌍 adventure-platform-fabric 5.1.0#

Released on 2022-02-28 - GitHub

This release of adventure-platform-fabric now ships MiniMessage, and updates the bundled Adventure to 4.10.0.

Supports 1.18 and 1.18.1.

What's Changed

  • Begin on integrating MiniMessage by @zml2008 in #17
  • Adventure update to 4.10.0

Full Changelog: v5.0.0...v5.1.0

v5.0.0: 🌍 adventure-platform-fabric 5.0.0#

Released on 2021-12-01 - GitHub

Changes

  • Target Minecraft 1.18 and Java 17
  • Remove deprecated API

v4.1.0: 🌍 adventure-platform-fabric 4.1.0 (MC 1.17.x)#

Released on 2021-11-28 - GitHub

Changes

  • Target Minecraft 1.17.x and Java 16

v4.0.0: 🌍 adventure-platform-fabric 4.0.0 (MC 1.16.x)#

Released on 2021-11-28 - GitHub

First stable release providing Adventure 4.9.3 integration on Minecraft: Java Edition 1.16.2-1.16.4 with Fabric Loader

1.0.1#

Released on 2020-04-18 - GitHub

  • Update to text 3.0.4